Remove Ads

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mail Server Rejecting Certain Domains
After a few years of regular and reliable emails, our Mail Server has started refusing emails from certain providers.
These include: (I think) (a UK insurance company), rec'd from them on 04/01/19, by 11th could not receive)
I don't recall doing anything to the mail server in that time.
I can run a test on the mail account on the server in Windows mail set up, where by it logs in to the receiving server, then the sending server, sends a test email, and then a few moments later this is received OK from an account hosted on the mail server.
The IP address of our mail server is static, and all the MX & A records etc. are correctly set up and have been working reliabily for years.
I cannot ping the mail server from the internet, because ping is blocked by the firewall, but, the mail ports are not, and I can recieve from some accounts for example two of my business accounts which are hosted on servers elsewhere.
Apart from whitelisting these domains, which I have tried, and it doesn't seem to work, unless I have completed the rule incorrectly.
I do have one set of returned email header after the email was continuously refused.
Can anyone help to diagnose this please?

Can you confirm if you can receive mail from the mentioned domains/services if you turn off (uncheck) “Enable SPF Verification”?
This is under security > authentication tab in mail server package. Not sure where would it be under the plus version.

Assuming that you’ve enabled this option.
DS216+II : DS118 : APC Back UPS ES 700 : Mac user
Thanks for the suggestion.
I've turned SPF off for now as a trial, but it has been on with the system working for years OK.
Apparently according to the errors we are getting back our server is simply not responding to the requests to deliver on port 25.
However, I can telnet into port 25 and manually enter smtp commands and send an email out.
Port 25 is this proved as open back to the mail server as required.
As are all of the other mail ports that I should need for mail.
25, 465, 587, 993

What has confused me is that it simply stopped working, I do not recall logging in to make any changes to the mail server.
It’s a shot in the dark. But let’s try. For me it was the DNS not being able to resolve for some domains when SPF is turned on and was fixed by installing DNS server on the DS. So I’m thinking maybe something has changed on the DNS server side.

On a different note, do you have the firewall blocking anything on 25? Since you’re saying it’s not responding at all to some requests. It sounds silly, but just checking the sequence of the rules might point to something or even disabling the firewall altogether for a brief test.

Also, have you tried examining the “maillog” file for any clues?
On my DS118 it’s under /volume1/@maillog
DS216+II : DS118 : APC Back UPS ES 700 : Mac user

Forum Jump:

Users browsing this thread:
Remove Ads